NexBlue - Official Website Unavailable – Incident details
All systems operational
Official Website Unavailable
Resolved
Major outage
Started about 1 month agoLasted 9 minutes
Affected
Website
Major outage from 9:07 AM to 9:16 AM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
We are currently experiencing an unexpected outage on our website due to an issue with Cloudflare. Thank you for your patience — we will provide updates as soon as we have more information.